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Introduction 

Welcome 
ZebraDesigner software is a family of labeling software products which provides a complete 
bar code and RFID Smart Label printing solution for desktop users. ZebraDesigner has an 
easy-to-use interface and meets any label design and printing requirement for efficient label 
printing solutions for users in retail, logistics, health care, chemical, automotive, and other 
industries. 

ZebraDesigner can be used with any 32-bit Windows® operating system: Windows 98 SE, 
Windows NT® 4.0, Windows ME, Windows 2000, Windows XP, and Windows Server ™ 
2003. 

You can use ZebraDesigner™ for mySAP™ Business Suite to design your label templates, 
export the templates, and parse them through the Format Generation Wizard. The resulting 
label templates are used for off-line label printing with data from mySAP™ Business Suite. 

Contents of the package 
Before installing ZebraDesigner™ for mySAP™ Business Suite, check the contents of the 
package to ensure it is complete. The package should include the ZebraDesigner™ for 
mySAP™ Business Suite CD and a sticker on the inside of the case that displays your serial 
number for the product. This serial number must be entered in order to use the software. 

If any of the mentioned items are missing, please contact your software vendor immediately 
for package replacement. 
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About this Manual 
The ZebraDesigner™ for mySAP™ Business Suite Quick Start Guide helps you design and 
print labels quickly. 

The Quick Start Guide contains the following sections: 

Introduction: This chapter introduces you to ZebraDesigner™ for mySAP™ Business Suite. 

Installation and Activation: This chapter shows you how to install and activate the labeling 
software. 

Design Labels: This chapter shows you how to create labels. You should refer to this chapter 
regularly while designing labels, until you have completely familiarized yourself with the 
commands. By using the information contained in this chapter, you will be able to use 
labeling software quickly and efficiently. 

Typographical Conventions 
Bold text refers to: 

• menu names 

• file names (SETUP.EXE) 

• interface buttons (OK) 

• PC keyboard keys (Alt) 

• menu flows (menu flows have a > that separates one menu from the next menu, for 
example Start > Programs > ZebraDesigner for mySAP) 

Italic text refers to: 

• graphic captions 

• text you need to type 

• locations  

• dialog box names 
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Installation and Activation 

System and Software Requirements 
These are the minimum requirements needed to run ZebraDesigner™ for mySAP™ Business 
Suite: 

• Pentium®-based computer with at least 64 MB of RAM 

• One of the 32-bit Windows operating system: Windows 98 SE, Windows NT 4.0, 
Windows ME, Windows 2000, Windows XP (Home or Professional editions), and 
Windows Server 2003 

• Hard disk with 75 MB of free disk space 

• CD-ROM drive 

• Administrator rights to the local computer during installation 

Install Overview for ZebraDesigner™ for mySAP™ 
Business Suite 
When you put the ZebraDesigner™ for mySAP™ Business Suite CD in your CD-ROM 
drive, the installation/demonstration program automatically starts. You can browse the 
directory of the CD and look at the brochures, technical documentation, sample files, and 
other documents on the CD. 

Note: If you are using Windows NT, Windows 2000, Windows XP, or Windows Server 
2003 you have to log on with Administrator rights to perform the installation. 

Close All Software Applications 
Before you start installing ZebraDesigner™ for mySAP™ Business Suite, close all other 
software applications. This ensures a complete installation of ZebraDesigner™ for mySAP™ 
Business Suite. 
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Run Installation 
To install ZebraDesigner™ for mySAP™ Business Suite on your desktop PC, do the 
following: 

1. Insert the ZebraDesigner™ for mySAP™ Business Suite CD into your CD-ROM 
drive. The Setup Wizard dialog box opens. 

Note: If the Setup Wizard does not start automatically, go to the main CD directory of 
your ZebraDesigner™ for mySAP™ Business Suite CD and double-click Setup.exe. 

2. Follow the prompts and make your selections accordingly. 

3. Click Install.  

4. Click Finish.  

Define Setup Options 
To continue the installation, do the following: 

1. Click Next. 

2. Specify the program group you want to use for ZebraDesigner™ for mySAP™ 
Business Suite. 

3. Specify if shortcuts to ZebraDesigner™ for mySAP™ Business Suite should be 
created on the desktop or in the Quick Launch area. 

4. To finish the installation, click Install. 
 
After installation you are asked to install a printer driver. You must install a 
ZebraDesigner driver. If you do not install a printer driver while installing the 
software, you are asked to install one the first time you run the program. 

5. After the installation is complete, the Start menu in Windows shows a new program 
group for ZebraDesigner™ for mySAP™ Business Suite. The program group contains 
shortcuts for all ZebraDesigner™ for mySAP™ Business Suite applications. 

Install Printer Driver 
To install the ZebraDesigner printer driver on your computer, do the following: 

1. Click Start > Programs > ZebraDesigner for mySAP. 

2. In the group ZebraDesigner for mySAP, click the shortcut Add printer. The printer 
installation wizard starts. 

3. Follow the prompts. 
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Register ZebraDesigner™ for mySAP™ Business Suite 
To activate all of the features of ZebraDesigner™ for mySAP™ Business Suite, you need to 
register the product. If you do not complete the registration process, ZebraDesigner™ for 
mySAP™ Business Suite runs in DEMO mode only. 

To register the software, do the following: 

1. Start ZebraDesigner™ for mySAP™ Business Suite. The DEMO dialog box opens. 

2. Click Register. 

3. Enter the required information and follow the prompts. 

ZebraDesigner for mySAP Demo Mode 
When ZebraDesigner™ for mySAP™ Business Suite is running in the demo mode, it has 
limited functionality. The major limitation of ZebraDesigner™ for mySAP™ Business Suite 
demo mode is that two text objects with the contents DEMO are added to each printed label. 

You should use the DEMO version only to evaluate ZebraDesigner™ for mySAP™ Business 
Suite. Any commercial use of the DEMO version is prohibited. To get a full working version 
of ZebraDesigner™ for mySAP™ Business Suite, you must purchase and register the 
software. 
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Design Labels 

Overview 
This section shows you how to design a label file with fixed and variable objects. You will 
learn how to: 

• Place objects on the label 

• Link objects to the variables 

The label you create will look like this: 

 
Basic label 

Create a Basic Label 
Each time you create a new label, the Label Setup Wizard starts to help you set up the label 
and connect to the printer. 

To create a basic label, do the following: 

1. Open ZebraDesigner™ for mySAP™ Business Suite. 

2. In the Standard toolbar, click . The Label Setup Wizard dialog box opens. 

3. Follow the prompts.  

Note: To exit the Label Setup Wizard dialog box, click Finish. 
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Select a Printer 

To select a printer, do the following: 

1. From the menu, select File > Label Setup. 

2. Select the printer you want to use for label printing. 

Note: If you don’t find your printer on the list, see Install Printer Driver for 
installation instructions. 

 
Selecting a printer 

3. Click Next.  

Define Label and Page Dimensions 

To define the label dimensions, do the following: 

1. If you want to use label stock, make your selections in the Select Stock dialog box.  

2. Click Next. The Page Size dialog box opens to define the label dimensions. 

3. Leave the Page size option at User defined default, and check Automatic Sizing.  

4. Click Next. The Label Layout dialog box opens. 
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Selecting label layout 

5. Select label orientation and print direction. 

6. Click Next. The Label Dimensions dialog box opens. 

Note: The Label Dimensions dialog box differs for thermal and office printers.  

 
Defining label dimensions 
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7. Enter your desired label width and label height.  

Note: To change the unit of measure from centimeters to inches or other supported 
units, click Unit of measure below the label preview. 

8. Click Finish. A new blank label opens. 

Enter Fixed Text 

1. In the Toolbox, click . The text cursor appears on the screen. 

 
Cursor for text object 

2. Move the cursor to the location on the label where you want to place the text object, 
and click the mouse button. The Text Object dialog box opens. 

 
Entering content for text object 

3. In the text box, type SAMPLE. 

4. Click Finish. 

5. To select the object, click it. 

6. Using the Text toolbar, you can select the font for the text object.  
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Using format options in the Text toolbar 

7. To change the position and size of the text object, select the text object and drag it 
with your mouse to the position you want. 

The screen should show the following: 

 
The text object is placed on the label 

Insert Bar Codes 

The following is an example of how to add a bar code on the label. In this example a non-
changing Code128 bar code is used.  

To add a non-changeable Code128 bar code on the label, do the following. 

1. In the Toolbox, click . 

2. Move the cursor to the desired position on the label and then click the mouse button. 
The dialog box with object properties opens. 

3. Enter the value 1234567890 for the bar code contents. 

4. Click Define. The Edit Bar Code dialog box opens. 
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Selecting bar code type 

5. In the Available bar codes list, select bar code Code128. 

6. Click OK. 

7. To return to the label, click Finish. 

8. To change the position of the bar code, select the bar code and drag it to the desired 
position. 

9. To change the object size, drag the object handles. The handles are small rectangles 
surrounding the object when it is selected. 

The label should now show the following: 

 
Label with text and bar code objects 
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Insert Pictures 

ZebraDesigner™ for mySAP™ Business Suite works with BMP, PCX, GIF, WMF, JPEG, 
and many other popular graphic formats. 

To insert a picture, do the following: 

1. In the Toolbox, click . 

2. Move the cursor to the desired position on the label and click the mouse button. The 
Open dialog box opens allowing you to browse for a picture on your hard drive.  

3. From the Graphics Kind dialog box, click Browse.  

4. Go to the Sample Graphics folder and select LEISURE.WMF.  

5. Click Open. 

The screen should show the following: 

 
Label with text, bar code, and picture objects 

Save a Label 

Always save your label during the design process.  

To save a label, do the following:  

1. In the Standard toolbar, click . 

2. Type in the name of the label. For example, type label for the name of the label. 
The name of the label appears in the program caption. 
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Use Alignment Tools 

Once you place the objects on the label make sure they are aligned in the desired location on 
the label. You can align objects on the label by using the Align toolbar on the right side of the 
working window. 

To align objects on the label, do the following: 

1. In the Toolbox, click . 

2. To select all of the objects, draw a frame around all of them. 

Note: The first object you select determines the alignment orientation for all selected 
objects. 

 
Selecting the objects on the label 

3. To center the objects on the label, hold down Ctrl button, and click  in the Align 
toolbar. The selected objects are rearranged and positioned on the center of the label. 

Note: 
 
• The Align toolbar has other alignment commands available. 
 
• You can also align the objects to the label grid. The Snap to Grid option is available in 
the View menu. 

Use Drawing Tools 

To insert a line to separate a text object from other objects and a rectangle around the picture 
object, do the following: 

1. From the Toolbox, click  and move the cursor to the required starting 
point of the line. 

2. While drawing the line, press and hold down the mouse button. Move the mouse to the 
end position of the line and release the button. The Line object is placed on the label. 

3. In the Toolbox, click  and point the mouse to the upper left corner of 
the picture. 
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4. While you stretch the rectangle to the lower right corner of the picture, click and hold 
the mouse button. 

5. To change the thickness of the vertical and horizontal line, double-click on the 
rectangle object to open its properties.  

6. Select the thickness you want. 

7. Click Finish. 

8. To edit the drawing object, double-click on the line or rectangle to open the dialog box 
with its properties. 

The label should show the following: 

 
Label with fixed objects 

Add Variable Fields 

Overview 

If you want to print a label on which the data changes for each label, ZebraDesigner™ for 
mySAP™ Business Suite offers different variable fields (date/time fields, link to the variables) 
that you can use with text, picture, and bar code objects. 

For this example, a new label was created. The steps in the following topics explain how to 
create a label that contains a variable field and date/time fields.  

Create Variable Fields linked to Variables 

The object on the label that is linked to the variable can have a different value for each printed 
label. 

To create a text object linked to the variable, do the following: 

1. In the Toolbox, click . 

2. Click the label where you want to place the text object. The Text Wizard dialog box 
opens. 

3. For the Contents, select Variable text. 

4. Click Next. 

5. Select Variable Field. 
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6. Click Next. 

7. Select one of the existing variables in the list. If no variable is available in the list, you 
must create some.  

8. Click Finish.  

9. Click Finish. The text object is placed on the label and linked to the selected variable. 

Note: This example shows how to create a text field linked to the variable. You can use 
the same approach to create and link a variable to the bar code object. 

Create Date and Time Variable Fields 

Content of the variable field can be filled automatically with the date or time stamp from the 
computer clock or printer clock (for supported printer models). 

To place a date field on the label, do the following: 

1. In the Toolbox, click the arrow  . 

2. From the list, select New Date Field. 

 
Creating new date variable field 

3. Click on the label where you want to place the object. The Date dialog box opens. 

4. Leave everything as default. The date is used on the label using the selected format. 

5. Follow the prompts.  

 

Use Prefix or Suffix Options 

You can add a prefix and suffix to date and time variable fields on the label. Both are added to 
the value when you print the label. 

To add the prefix to the date or time variable field on the label, do the following: 

1. In the Toolbox, click the arrow . 

2. From the list, select New Time Field. 

3. On the label, click where you want to place the object. The Text Wizard dialog box 
opens. 

4. Click Next. 

5. Enter Time: for the Prefix option. 
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Defining the variable prefix 

6. Click Finish. The text object is placed on the label and linked to the new variable. 
When you print the label, the prefix Time: will be appended to the time value on the 
left side. 

Resize Variable Fields (Shift-dragging) 

The size of the variable fields on the label is determined by their sample data. The sample 
data is defined during the variable creation process. The text object on the label is always as 
wide as the width of the sample data formatted in the font. 

If the values for the variable always occupy the same length or less than the sample data, the 
label will print as expected. If data provided at print time is longer than the sample data, the 
text object can overlap other objects. 

To avoid overlapping, you can resize the variable fields on the label. 
To resize the variable fields on the label, do the following:  

1. Select the variable text object on the label. 

2. Press and hold the Shift key. 

3. Using your mouse, grab and hold the center right object handle and drag to resize. The 
new object frame defines the maximum size that the variable value can occupy on the 
label. 

For example, you entered SAMPLE for the sample data. You then resized the object for one 
additional character to the right side. When you print the label with value DESIGNER, the 
whole text is not printed. The text that does not fit into the designed frame will wrap onto the 
beginning of the field. 
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Design an RFID Smart Label 
Radio Frequency Identification (RFID) refers to technologies that use radio waves to 
automatically identify individual or groups of items. ZebraDesigner™ for mySAP™ 
Business Suite and ZebraDesigner printer drivers support programming and printing of RFID 
tags embedded in a label.  

Note: You can use RFID functionality in ZebraDesigner™ for mySAP™ Business 
Suite only if you have installed a ZebraDesigner printer driver with RFID support. 

Create RFID Encoding Label 

1. In the Standard toolbar, click . The Label Setup Wizard dialog box opens. 

2. Select the printer that supports RFID smart label printing. 

3. Click Finish. In the Toolbox, on the left side of the working window, the RFID tag 
command is enabled. An image of an RFID tag appears on the screen. The image will 
not print on the labels. The image does not indicate the position, size, or RFID type, 
but is only shown to indicate that RFID commands will be used.   

 
RFID tag is available for use 

 



ZebraDesigner™ for mySAP™Business Suite Quick Start Guide 

18 

Encode RFID Tag 
The RFID tags that are embedded into the label are usually one of these types:  

• ISO tags, which encode blocks of data 

• UHF tags, which can encode one string of data. 

1. To begin encoding the data, in the Toolbox, click . The RFID tag 
dialog box opens. 

 
Encoding contents for RFID tag 

2. From the Type list box on the top of the dialog box, select the type of RFID tag you 
want to use. 

3. Select the Use RFID tag in label option.  

Note: If you don’t select this option, the definition of tag content is saved but not sent to 
the printer. 

4. In the Data Block section, from the Data Type drop-down, select HEX or ASCII.    

5. Enable the Element radio button and select the desired variable.  

6. Click OK. An image of the RFID tag antenna displays on the label background. 
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RFID tag antenna in the background 

7. You can continue designing the smart label with non-RFID data as described in the 
previous sections. 

When you print the label, the RFID data is sent to the printer. The printer prints the RFID 
smart label and programs the RFID tag embedded into the label at the same time. 

Note: ZebraDesigner™ for mySAP™ Business Suite can also work with Unique RFID 
tag numbers when a tag is used that has a Unique Tag Identifier. 

Change Common Printer Settings 
When you start designing a label, tell ZebraDesigner™ for mySAP™ Business Suite what 
printer to connect the label to. Each label file remembers the printer settings for the selected 
printer driver on the label. 

This example shows you how to change the printing speed and darkness.  

To change the printer settings, do the following: 

1. From the menu, select File  > Printer Settings. The dialog box with the printer 
settings opens. 

2. From the Options tab, change the Speed and Darkness options.  

3. Click OK. 

4. To save the label, in the Standard toolbar, click  . 
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Printer driver properties 

Change Dithering Type 
Dithering is a process of converting color or gray scale pictures to black and white pictures 
that can be printed on thermal printers. There are no intermediate shades of gray. 

During the dithering process, all colors and shades of gray in the picture are converted to 
black and white dots, creating the illusion of new colors and shades by varying the pattern of 
dots. Different shades of gray are produced by varying the patterns of black and white dots. 
There are no gray dots at all. In printing, dithering is usually called half-toning. Shades of 
gray are called half-tones. 

To change the dithering type, do the following: 

1. From the menu, select File > Printer Settings.  The Printer Properties dialog box 
opens. 

2. Open the Dithering tab. 

3. Enable the Dithering Type that suits your needs. Look at the preview on the right side 
to view example. 

4. Click OK. 

5. To save the label, in the Standard toolbar, click  . 
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Work with Variable Data 

Dynamic Data Overview 
You may want to print labels where the data changes for each label, for example, serial 
numbers, date, and time. To accommodate the changing data, ZebraDesigner™ for mySAP™ 
Business Suite can be used to format labels using the variable fields. Variable fields can be 
used with text and bar code objects. 

There are several types of variables you can choose. The data for the variables must be 
provided before the label can be exported:  

• Before the label can be printed, you must provide the values for the variables. 

• The data is provided from the printer’s clock for the date and time fields (internal 
printer RTC). 

• The data is provided from the RFID tag embedded in the label (RFID tag Unique ID). 

Create Single-Line Variable 
As the name suggests, you can use a single-line variable in one line of text on the label. 

To create a single-line variable on your label, do the following: 

1. Make sure the Variable toolbar is visible. If it is not, select View > Toolbars > 
Variable. 

2. In the Variable toolbar, click . The Variable Wizard dialog box opens. 

3. Enter the name of the variable. Use a descriptive name so that you know what the 
variable contains. 

4. Click Next. 

5. Enter the Sample data. When you link your variable to the label object, the sample 
data will be used for the contents of the object. The sample data is shown during label 
design only. 

Note: When you print the label, the variable uses the data you provide, not the sample 
data. 

6. Click Finish. 
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Create Multiline Variable 
As the name suggests, you can use a multiline variable with more lines of text in the text 
object on the label. The variable can contain as many characters in each line as you specify.  

To create a multiline variable on your label, do the following: 

1. Make sure the Variable toolbar is visible. If it is not, select View > Toolbars > 
Variable. 

2. In the Variable toolbar, click . The Variable Wizard dialog box opens. 

3. Enter the name of the variable. Use a descriptive name so that you know the variable 
contents. 

4. Click Next. 

5. Enable the Multiline Variable option. 

6. Enter the Sample data. 
When you link your variable to the label object, the sample data is used for the 
contents of the object. The sample data is shown during label design only. Use the 
Enter key to advance to the next line of text. 

Note: When you print the label, the variable uses the data you provide, not the sample 
data. 

7. Click Finish. 

Control Text Field Widths and Multiline Fields 
Sometimes you may want to control the width of the variable text field. This is useful for 
ensuring correct text alignment and justification. At print time, if the width of the field set on 
the label template is not large enough, the text may word wrap on itself on the same line. This 
results in what looks like corrupt data.  

To control the field width, do the following: 

1. While holding down the Shift key, drag the middle right handle of the field. This 
method establishes the width of the text object frame. Once a field has been set using 
this method, it is easy to use the justification buttons in the Standard toolbar to set left, 
center or right justification for the field. 

Another method is necessary when creating multiline variable fields.  

To set up the Sample data in the Variable Wizard, do the following:  

1. From the menu, click .  

2. In the Sample data text box, type the name of the variable and click Next. The 
Variable properties dialog box opens: 
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Variable Wizard dialog box 

3. To establish a multiline variable type, click the Multiline Variable check box. The 
Number of Lines value increases each time you press the Enter key while entering 
your Sample data. When used as a Text Field variable, a Multiline variable will result 
in a field that uses the number of lines you defined in the variable. In this method you 
can also use the justification buttons in the design environment to set left, center, or 
right justification for the field. 

This is an example of a field that has been set to a controlled width using the Shift-dragging 
method, and then set to center justification. At print time, data sent to this field will occupy 
the defined width, in a center justification: 

 
 This is an example of a field that has been created using a multiline variable and set to left 
justification: 
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These two methods can be used together to create variables fields with known width, 
multiline, and justification properties as shown below: 

 
Note: This method requires the use of a font that is internal to the printer, such as the 
scalable Zebra Font 0 or Zebra Swiss Unicode.  

Using Printer Real Time Clock (RTC) 
When the printer selected on the label has a built-in Real Time Clock (RTC), you can use the 
time or date fields from the Real Time Clock with text objects on the label. The available time 
and date formats are defined in the printer driver. 

To use the time field from the printer RTC on the label, do the following: 

1. In the Toolbox, click . 

2. Click the position on the label where you want to place the object. The Text Wizard 
dialog box opens. 

3. Enable the Variable text option. 

4. Click Next. 

5. Select the Time Field option. 

6. Click Next. 

7. Select the appropriate time format from the list.  
The printer driver provided the software with the list of available time formats. You 
cannot define your own time format. It is determined by the printer functionality. 

8. Click Finish. 

Note: When you are using a prefix and suffix with the Real Time Clock field on the 
label, make sure that the combined length of the prefix and suffix does not exceed 31 
characters. When you are using a linked field and are merging a Real Time Clock field 
with other fields, make sure that the combined length of fields surrounding the Real 
Time Clock field does not exceed 31 characters. 
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Increment Variable Fields 
Creating incrementing variable fields means that the Zebra printer will increment a mySAP™ 
Business Suite variable field This field will increment if the print quantity is greater than 1. 
 You can create incrementing variable fields for text and bar codes.  

Note: These steps show you how to create a text incrementing variable field.   

To create a incrementing variable field, do the following: 

1. In the Toolbox, click  . 

2. Click the label where you want to place the text object. The Text Wizard dialog box opens. 

3. For the Contents, select Variable text. 

4. Click Next. 

5. Select Variable Field. 

6. Click Next. 

7. Click New. 

8. Type in a variable name. 

9. Click Next. 

10. Click Next. The Automatic Incrementing dialog box opens. 

 
Automatic Incrementing 

11. Select Enable printer incrementing. 
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12. Select the increment amount. 

Note: Cut leading zeros: 
• When you enable this checkbox it causes any leading zeros to be truncated from the 
output value. If the field width is 5 digits, a value of 123 will print as 00123.  
• When you disable this checkbox, if the field width is 5 digits, a value of 123 will print 
as 00123. 

13. Make a selection for Cut leading zeros.  

14. Click Finish.  

15. Click Finish. 

Note: This example shows how to create a text field linked to the variable. You can use 
the same approach to create and link a variable to the bar code object. 

Variable Graphics 
Variable graphics objects are only available when the label is configured to use a graphic 
image that has been downloaded to the printer with the font and graphics downloader. For 
instruction, see the ZebraDesigner™ for mySAP™ Business Suite Font and Graphics 
Downloader User Guide. 

When creating a variable graphic on the label, ZebraDesigner™ for mySAP™ Business Suite 
displays a question mark to indicate a field is based on a variable.   

Note: You cannot resize or rotate the variable graphics object. 

To create a variable graphic: 

1. Before creating a variable graphic, you must have a graphic already on the memory 
card. For details, click here.  

2. In the Toolbox, click . 

3. Move the cursor to the desired position on the label and click the mouse button. The 
Open dialog box opens allowing you to browse for a picture on your hard drive.  

4. From the Graphics Kind dialog box, enable Variable. 

5. Click Next.  

6. Click New. The Variable name dialog box opens. In the Variable name text-box a 
default variable name appears. It begins and ends with "&". If you want to change the 
variable name, be sure to leave the "&" before and after the variable name.  

7. From the Variable name dialog you can assign a special variable. To do so, enable the 
This is a special variable check box, enable the type of special variable you want and 
click Next. The Variable Properties dialog box opens.  

8. Make your selections accordingly. 

9. Click Next. 

10. If a script is needed, enable Use script and populate the text box accordingly. 

11. Click Finish.  
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12. Click Finish.  

 

To edit a existing variable, do the following: 

1. Before creating a variable graphic, you must have a graphic already on the memory 
card. For details, click here.  

2. From the Variable toolbar, click the arrow in the variable name field. 

 
Variable list 

3. Select the variable you want to edit and click on the label. The Variable Field dialog 
box opens. 

4. Click Edit.  

5. Make the desired changes. 

6. Click Finish. 

7. Click Finish. 

Variables Tied to Print, Copy, and Cut Quantity 
Create Variables Tied to Print, Copy and Cut Quantity allows you to specify that these 
parameters will be defined by this mySAP™ variable.   

For example, this feature could be used to control the number of labels to be printed from 
within the mySAP™ Business Suite. 

If no object is selected on a label and you select one variable from the list, this variable 
becomes the current selected variable. When a new text or bar code object is added the new 
object will be connected to the selected variable.  

1. In the Toolbox, click  . 

2. Click the label where you want to place the text object. The Text Wizard dialog box 
opens. 

3. For the Contents, select Variable text. 

4. Click Next. 

5. Select Variable Field. 

6. Click Next. 

7. Click New. The Variable name dialog box opens. 
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Variable name 

8. Select This is a special variable.  

9. Select the type of special variable you want. These are your choices: 

Print Quantity: the number of labels to be printed.  If there is a counter field, it 
typically increments for each label printed. The default is 1. 

Copy Quantity: the number of copies of each label to be printed. This causes multiple 
copies of the same label to be printed. This does not cause the counter to be 
incremented.  The default is 1. 

Cut Quantity: only valid when using a cutter on the printer. It determines the number 
of labels to print before cutting.  The default is 1. 

10. Click Next. 

11. Click Finish. 

12. Click Finish. 

Scripts 
The contents of this dialog are SAPscript and the processing is done by mySAP™ Business 
Suite. ZebraDesigner™ for mySAP™ Business Suite does not do any pre-processing, so 
please ensure that the syntax works correctly. The main purpose for this advanced dialog box 
is to allow you to embed SAPscript within the label design. This means that you should never 
need to manually modify the ITF file generated by ZebraDesigner™. If you manually 
modified the output, then required a change to the label to be made within ZebraDesigner™, 
you would lose these manual modifications when you re-generate the output from 
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ZebraDesigner™. This means that you will be able to easily make graphical modifications to 
labels at any point in the future and not lose any SAPscript coding. 

1. From the Variable toolbar, click the arrow in the variable name field. 

  
Variable list  

2. Select the variable you want to edit and click on the label. The Variable Field dialog 
box opens. 

3. Click Edit. The Variable Properties dialog box opens. 

4. Make your selection. 

5. Click Next. The Automatic incrementing dialog box opens.  

6. Click Next. The Script Definition dialog box opens.  

7. Enable the Use Script check box you want to use the advanced variable data features 
of ZebraDesigner™ for mySAP™ Business Suite.  

8. Enter the variables.  

9. Click Finish. 

Use Variable Wizard 

Variable Wizard 

Use the Variable Wizard to create and manage the variables in the label file. When you assign 
a value to the variables, the same value is used with all objects on the label that are linked to 
the variable. 

The variables can be linked to Text and Bar Code objects. 

To create a variable follow the prompts. 

Define Variable Name 

You can define the variable name and quantity information in this step of the Variable 
Wizard. 

Variable Name: Type in the variable name. The variable name is included in the exported 
label. Make sure you use the proper variable name that is recognized by the Format 
Generation Wizard. 

Note: The default start and stop tags are & and &. These characters define the 
beginning and end of the variable name.  
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This is a special variable: If the value of the variable contains the quantity information that 
must be included in the exported label format, click this option. 

Use var for Print Quantity: The variable identifies how many labels print. When you 
export the label format, the exported file has this variable included with the print 
command for label quantity. 

Use var for Copy Quantity: The variable identifies how many identical label copies 
print. When you export the label format, the exported file has this variable included 
with the print command for label copies. 

Use var for Cut Quantity: The variable identifies how many labels are printed before 
the printer pauses. When you export the label format, the exported file has this variable 
included with the cut command. 

Note: The Use var for Cut Quantity option is available only when the selected printer 
has the option to use the cutter. 

Define Variable Properties 

You can define the variable data properties in this step of the Variable Wizard. 

Sample data: Enter the appropriate data for the variable. The entered data will be used for 
design and preview functionality. You will assign the variable with its proper value outside of 
ZebraDesigner™ for mySAP™ Business Suite. 

Multiline Variable: If you want to enable multiline functionality for the variable, click this 
option. You are able to enter more than just one line of sample data. 

Note: To move to the next line of text, press Enter. 

Maximum number of characters: Define the maximum number of characters that the 
variable can occupy. The number defined must correspond to the external application that will 
actually set variable values. 

Number of lines: Define the multiline variable. Enter the number of lines the variable can 
occupy. 

Define Script 

You can define a script that is included in the exported label format. This feature is optional. 

The Format Generation Wizard in ZebraDesigner™ for mySAP™ Business Suite includes 
the variable in the proper formatting in the exported label file. You can override the default 
settings and include some special parameters or commands with the variable name. Define a 
script and include not only the variable name in the script but other parameters and commands 
using Zebra Programming Language (ZPL). 

Note: This feature is for advanced users only. You must be familiar with ZPL to 
successfully use the Script option. 

Use script: Click this option to enable the script option. Write your script in the provided 
space. Make sure you include the variable name in the script. 
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Export to Printer 

To verify the printout of your label, from the menu, select File > Test Print. When you are 
satisfied with the designed label, you can export the label to the printer. During the export 
process, ZebraDesigner™ for mySAP™ Business Suite runs the Format Generation Wizard 
and converts the label format to a supported Zebra printer. 

The generated file includes commands from the Zebra Programming Language (ZPL) and is 
ready to be used in the printer for off-line printing. 

Note: Off-line printing is a term that describes the type of label printing where the label 
design application is not available at print time. Usually the label format is stored in the 
memory of the printer and can be recalled. Off-line printing support is great for print 
requirements where the PC computer cannot be included in the label printing process 
either because of unacceptable working conditions or logistic issues. 
Off-line printing also provides faster label printing because all variable objects on the 
label use internal printer functionality. 

To export the label to printer, do the following: 

1. From the menu, select File > Export to Printer. The Download Objects dialog box 
opens.  

 
Download Objects dialog box 
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To choose one of the options, do the following: 

1. Select the option you want. 

2. Click Next. The Printer Object Location dialog box opens. 

 
Printer Object Location dialog box 

1. Select the Printer Storage Location you want.  The memory types include:  

• A-Flash = Option Flash memory 

• B-Flash = Flash memory card (PCMCIA) 

• E-Flash = internal Flash memory 

• R-DRAM = volatile memory 

2. Type in a format name.  

3. Click Next. The File Destination dialog box opens. 
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File Destination dialog box 

In the File Destination dialog box you can navigate to where you want the file saved.   

To choose a file destination, do the following: 

1. Click Browse. The Browse for Folder dialog box opens.  

2. Navigate to the path where you want the file sent.  

3. Click OK.  The Browse for Folder dialog box closes and you return to the File 
Destination dialog box. The Enter Destination Path text-box is populated with the 
destination you selected in the Browse for Folder dialog box.  

4. Click Next.  The Format Generation Wizard dialog box opens. From this dialog box 
you can:  

• Send File: the Send File button sends your file to the selected path 

• Cancel: the Cancel button stops the file from being sent  

• Help: the Help button opens help for the Format Generation Wizard 

5. Select Send File. The Destination dialog box opens.  
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Destination dialog box 

In the Destination dialog box you can select where you want to send the file(s).  

These are your options: 

• Use Current Location 

• Send to Network Printer 

Use Current Location 
To send the files to the printer using the port that the ZebraDesigner driver is pointed to, do 
the following: 

1. Select Use Current Location from the Destination dialog box. 
2. Click Next. You return to the application.  

Send to Network Printer 
To send the files to a network printer, do the following: 

1. Select Send to Network Printer. 
2. Click Next. The Select Network Destination dialog box opens.  
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Select Destination dialog box 

In the Select Network Destination dialog box you can select the network destination you 
want to send the files to. Your options include: 

• Enter an IP Address 

• Valid network name 

• Search Print Server 

Enter an IP Address 
To select an IP address, do the following: 

1. Select Enter an IP Address. 

2. Enter a valid IP address. 

3. Click Next. You return to the application.  
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Enter a Network Name 
To select a valid network name, do the following: 

1. Select Network Name. 

2. Enter a valid Network Name. 

3. Click Next. You return to the application.  

Search Print Server 
When you select Search Print Server the Search Type dialog box opens. 

 
Search Type dialog box 
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In the Search Type dialog box you can choose to search for:  

• Local Broadcast 

• Subnet xxx.xxx.xxx.* 

• Directed Broadcast xxx.xxx.xxx.255 

• Multicast (Hops) 

• IP Address xxx.xxx.xxx.xxx.(-xxx) 

Local Broadcast  
Local broadcasts send a discovery request to the local broadcast address of 255.255.255.255. 
This request finds printers in the same local network as the requesting computer.  

The local broadcast search populates itself. 

To perform a local broadcast search, do the following: 

1. In the Search Type dialog box, select Local Broadcast. The Value field is 
automatically populated.  

2. Click Add. The Value field is added to Search type. 

3. Click Next.  

Subnet Search 
The subnet search sends a discovery request to each address in the specified subnet. This 
feature is useful for networks that prevent broadcast packets from passing across routers. The 
Subnet search requires you to type in the first three subnet octets.  

Example: A request to 192.168.2.* sends a request to: 192.168.2.1 through 
192.168.2.254. 

To perform a subnet search, do the following: 

1. From the Search Type dialog box, select Subnet.  

2. In the Value field, type the first three subnet octets. Then type an *. 

3. Click Add. 

4. Click Next.  



ZebraDesigner™ for mySAP™Business Suite Quick Start Guide 

38 

Directed Broadcast 
Directed broadcasts sends a discovery request to the broadcast address of the specified subnet. 

Note: If a broadcast search does not work, the broadcast packets might be disabled 
across routers. Try multicast or subnet search.  
Example: The directed broadcast search requires you to type in the first three subnet 
octets, followed by 255, such as 192.168.2.255. 

To perform a Directed Broadcast search, do the following: 

1. In the Search Type dialog box, select Directed Broadcast. The Value field is 
automatically populated.  

2. Click Add.  

3. Click Next. The Select Print Server dialog box opens.  

4. Using the buttons between the two panels, select the print servers you want.  

5. When you are finished, click Next.  

Multicast 
Multicast uses the multicast address to send a discovery address to all Zebra printers across as 
many routers as the hop count specifies. A multicast search may return a large number of 
printers in some installations. 

On some routers, this feature might be disabled. See your network administrator to determine 
if a search failure was due to this feature being disabled.  

To perform a multicast search, do the following:   

1. In the Search Type dialog box, select Multicast (Hops). The Value field is 
automatically populated.  

2. Click Add.  

3. Click Next. The Select Print Server dialog box opens.  

4. Using the buttons between the two panels, select the print servers you want.  

5. When you are finished, click Next.  
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IP Address 
To search for an IP address, do the following:   

In the Search Type dialog box, select IP Address xxx.xxx.xxx.xxx (-xxx). The Value field is 
automatically populated.  

For example, you would type in an IP address with a range, such as 10.3.4.97-200. 
1. In the Value field type in an IP address. 

2. Click Add.  

3. Click Next. The Select Print Server dialog box opens.  

 
Select Print Servers  dialog box 

Select Print Servers 
The Select Print Servers dialog box displays the available print server(s) that you selected. 
From this dialog box you can select the print servers you want to send the files to.  

To select print servers, do the following: 

1. In the Available Print Server(s) panel select the print servers you want and click the 
double right arrow button between the panels. The selected print servers move to the 
Selected Print Server(s) panel. 

2. When you are finished selecting the print server(s), select Next. You return to the 
application. 
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